Status
Back
Maintenance
Email configuration update
Completed 17 Jul at 01:41am EET.
Affected services
API Service
Completed
Maintenance completed
Posted 17 Jul at 01:41am EET.
Started
Backend will be down for email config update
Posted 16 Jul at 12:41pm EET.